PHP7.1にしたらこのブログの本文が表示されなくなった

先ほどのエントリー「Joomla! 3.7.0にアップデート」で記載したサーバーのMySQLのパスワード形式の変更については、大した手順ではなかったので、すぐに実施しました。
その後、PHPのバージョンをPHP5.6からPHP7.1に変更したところ、このブログにおいて、タイトルや下段のタグなどは表示されるものの、本文が何も表示されなくなってしまいました。
同じWordPressを利用した「そんな今宵もビールの用意だ」については何の問題もなく表示されることから、使っているテーマの問題のようです。
しかたないので、再度、PHP5.6に戻しました。

テーマを変更しないといけないのかなぁ・・・・・
それはとっても面倒だなぁ・・・・・
 
それと先ほどのエントリー「Joomla! 3.7.0にアップデート」においてwikiが表示されなくなったと書きましたが、もう一つ、BlognPlusで作成したブログも表示されなくなっていました。
うーん、これは困った・・・
しーゆー。
 
 
~ 追記 ~
BlognPlusはバージョン2.6.2→2.6.11aに更新したら復活しました。
よかった。

しかしBlognPlusは2017年5月31日に公開終了し、公式サイトも閉鎖されるということなので、一応今後のためにデータをエクスポートしておきました。

関連ニュース
公開終了及び、サイト閉鎖のお知らせ::BlognPlus(ぶろぐん+)

しーゆー。
 

Joomla! 3.7.0にアップデート

家族のサイトで利用しているCMSツール「Joomla!」をバージョン3.7.0にアップデートしました。
アップデート後、管理画面に「PHPのバージョンが古いのでアップデートしなさい」という内容の警告が表示されたので、借りているレンタルサーバーのLolipopにログインし、PHPのバージョンをPHP5.3から最新のPHP7.1に変更したところ、このブログを含む、MySQLを利用している全てのアプリが動作しなくなってしまいました。
よく見るとLolipopに以下のような注意事項がありました。

PHP7.1利用のドメインで簡単インストール、サイト表示ができません。 / CGI・SSI・PHPについて / よくある質問 / サポート – レンタルサーバーならロリポップ!

簡単インストールが失敗したり、サイトで「データベース接続確立エラー」が表示される場合、データベースのパスワード形式が影響している可能性があります。

ロリポップ!で提供しているPHP7.1では、セキュリティレベルが高いデータベース接続方法を採用しており、PHP7.1を利用しているドメインから、古いパスワード形式である「old_password形式」を利用しているデータベースへの接続を行うことができません。

PHP7.1利用のドメインで使用するデータベースは、パスワード形式が「native_password形式」となっている必要があります。

以下をご参照の上、ご対応ください。
(以下省略)

 
パスワード形式の変更手順も記載されていましたが、MySQLのパスワード形式の変更は後日行うことにし、PHPのバージョンをPHP5.6に変更しました。

これで、このブログを始め多くのアプリは動作するようになりましたが、Wikiだけ表示されません。
今は更新もしていないwikiなので、この際削除しますかね、、、
(´・ω・`)

ただセキュリティの問題もあるので、近いうちにMySQLのパスワード形式を変更し、PHP7.1に変更しなくては。
しーゆー。
 

MySQLに繋がらなくなった?

LolipopのサーバにインストールしていたアプリのいくつかがMySQLに繋がらなくなってしまった。

繋がらなくなったのは、
・zenPHOTO
・Joomla
・OpnePNE
他にもあるかも。

このブログを含むいくつかのWordPress利用のブログはいずれも問題なし。

困ったなぁ。。。
(´・ω・`)

やってもうた!

@Niftyで借りているレンタルサーバ(旧ラクーカン)のMySQLの設定変更を誤ったため、
@Niftyのレンタルサーバ上に設置していたMySQL利用のサービスが全部ぶっ飛んでしまいました。
あ~あ。。。

元には戻せないし、あきらめるしかない。。。。

さて、closedな環境をなにを使って作ろうかなぁ。
いまさらXoopsで作りなおす気にはならないし。。。

続・@Niftyからの回答

@Niftyから、がっかりな回答がきました。
本件はコレでおわりです。
ホント、がっかり。

【お問い合わせ内容】
MySQLのバージョンアップについて

【回答】
はじめに、前回の回答がお問い合わせの意図に沿わず、再度ご連絡のお手数
をおかけをおかけしたことをお詫びいたします。

また、お問い合わせいただきながら誠に恐縮ですが、LaCoocanにおけるデー
タベース(MYSQL)につきましては、現在バージョン変更の予定はございませ
ん。ご希望に沿えず申し訳ございませんが、何卒ご容赦ください。

 
 
My関連エントリー
@Niftyから回答 at 2011.01.03
@Niftyにメールした at 2011.01.02
WordPress2.9.2にバージョンアップできない件について
by WordPressなんて簡単さ、なんて嘘さ。 at 2010.05.24

@Niftyから回答

@Niftyさんより、先日の依頼に対する回答がきました。

   お問い合わせいただいた件について回答いたします。

【お問い合わせ内容】
「WordPress」のご利用について

【回答】
お問い合わせいただきながら、誠に恐縮ですが「LaCoocanサービスの簡単イン
ストーラー」で記載がございますアプリケーションは、弊社で、より簡単に
「LaCoocan」をご利用いただけるよう提案させていただいているものとなりま
す。

そのため、簡単インストーラーよりインストールができない場合の
「WordPress」のバージョンアップにつきましても、手動で行っていただく方
法などについて、ご案内はしておりませんため、ご自身の判断にて操作いただ
けますようお願いいたします。

このたびはお問い合わせをいただきながらお力添えが出来ず、大変申し訳ござ
いません。何卒ご容赦くださいますようお願い申し上げます。

その他、ご不明な点がございましたらご遠慮なくお問い合わせ下さい。
今後とも@niftyをよろしくお願いいたします。

@Niftyさん、私の依頼に対する回答になってないよ、、、
ということで、再度返信。

ご回答、ありがとうございます。

ただし、私の依頼の回答になっておりません。
私自身の判断で手動でWordPressのバージョンアップを行いたいのですが、
サーバのMySQLのバージョンが古くて、バージョンアップができないことを
問題にしております。
私自身の判断にて、私個人の責任で操作したいのに、「貴サーバの制限」で
できないのです。

セキュリティの問題があるバージョンを使い続けるか、バージョンアップするかは、
利用者の判断によるもので、@Niftyさんの責任の範囲ではないことは理解して
おります。

しかし、セキュリティの問題があるバージョンを使い続けたくないので、バージョン
アップしたいと利用者が思っても、バージョンアップさせてもらえないことを
問題視しています。

今回の回答内容は、
「セキュリティ的に問題のあるバージョンを使いたくない人は@Niftyは利用するな」
というようにも聞こえます。

ぜひとも、ラクーカンサーバをWordPressの最新バージョンを利用可能な環境に
していただきたくよろしくお願いいたします。

 
他の人からも文句あがってないのかなぁ、、、
それとも、ラクーカンでWordPress使っているバカは私だけなのかなぁ、、、
 
My関連エントリー
@Niftyにメールした at 2011.01.02
WordPress2.9.2にバージョンアップできない件について
by WordPressなんて簡単さ、なんて嘘さ。 at 2010.05.24

@Niftyにメールした

@Niftyのレンタルサーバ「ラクーカン」でWordPressのバージョンアップができない件について、@Niftyに以下のようなメールを出してみました。

WordPressの3.0.4がリリースされたので、バージョンアップを試みましたが、相変わらず、
「The update cannot be installed because WordPress 3.0.4 requires MySQL version 4.1.2 or higher. You are running version 4.0.27.」
ということでバージョンアップできませんでした。
今回のバージョンアップの内容は
「このアップデートでは HTML をサニタイズする KSES と呼ばれるライブラリーにあるコアのセキュリティバグを修正します。このリリースをランク付けするなら、”critical” (重要) になります。」
ということなので、セキュリティ的に考えれば、バージョンアップ必須と思います。
簡単インストーラで「WordPress」を掲載していながら、セキュリティ的に問題のある状態でしか使えないというのは、@Niftyとして問題ではないかと思います。
今の状態は、セキュリティパッチを適用していないWindowsを使用しているようなものです。
昨年同様の依頼を行いましたが、数ヶ月経っても同じ状態です。
セキュリティに対する@Niftyの姿勢を疑わざるを得ません。
一日も早く、WordPressのバージョンアップを行えるように、MySQLのバージョンアップを行っていただきたく、よろしくお願いします。

もっとも今は正月休みなので、回答は正月休み明けになってしまうのでしょうか。
だとすると、休み中にもかかわらずバージョンアップをリリースしたWordPressとのセキュリティに対する姿勢の違いが大きくなってしまいますが。
いつ、どんな回答が戻ってくるか、ちょっと楽しみ。

My関連エントリー
WordPress2.9.2にバージョンアップできない件について
by WordPressなんて簡単さ、なんて嘘さ。 at 2010.05.24