続・Firefox5

今日は・・・

ということで、FireShotとTomblooがOKになったようなので、Firefox5にアップデートしました。
ちょっぴり早くなった気がします。
ところで、今後Firefox6,7,8と6週間ごとにバージョンアップしていくそうですが、今後のアップデートはバックグラウンドで自動で更新されるようになっています。
ある日突然、こっそりFirefoxがバージョンアップして、Tomblooが使えなくなってるかも?
それは困るなぁ。。。
ということで、自動更新の設定を変更しました。
変更箇所は以下。

My関連エントリー
Firefox5 at 2011年6月23日

WordPress3.1.3にアップグレード

WordPressを3.1.3にアップグレードしました。
変更内容は以下。

WordPress 3.1.3、WordPress 3.2 ベータ 2
by WordPressブログ

WordPress 3.1.3 がご利用いただけるようになりました。これは、以前のバージョン全てに対するセキュリテイアップデートであり、以下のセキュリティ修正と改善を含んでいます。

Alexander Concha による各種セキュリティ強化
John Lamansky によるタクソノミークエリ関連の補強
カノニカルリダイレクトを利用した投稿者以外のユーザー名情報傍受の防止。Props: Verónica Valeros
Microsoft 社の Richard Lundee 氏および Jesse Ou 氏、また マイクロソフト脆弱性調査 によるメディアセキュリティの修正
危険なセキュリティ設定を行っているサーバー上でのファイルアップロードセキュリティを向上
インポートが完了しなかった場合古い WordPress インポートファイルを削除
モダンブラウザ上の管理画面及びログイン画面で、「クリックジャック」に対する防御策を導入

ということで、セキュリティアップデートなので、WordPress利用者は更新をお勧めします。

でも・・・
@Niftyのラクーカンサーバーの場合は、今日も相変わらず・・・

The update cannot be installed because WordPress 3.1.3 requires MySQL version 4.1.2 or higher. You are running version 4.0.27.

となってアップデートできないのよね。。。

WordPress3.1.2にアップデート

WordPressを3.1.2にアップグレードしました。

WordPress 3.1.2
by WordPressブログ at 2011.04.27

このリリースでは、貢献者権限グループのユーザーが投稿を不正に公開できてしまうという脆弱性に対応しています。

ということですので、WordPress利用者は早めにアップグレードした方がいいと思います。

ただし、@Niftyのラクーカンサーバを使っている場合は相変わらず

The update cannot be installed because WordPress 3.1.2 requires MySQL version 4.1.2 or higher. You are running version 4.0.27.

となってしまい、アップグレードできない状態が続いております。
ダメダメ@Nifty。

WordPress3.1.1にアップグレード

WordPressを3.1.1にアップグレードしました。
自動アップグレードをクリックして一瞬で完了しました!
変更内容は以下になります。

WordPress 3.1.1
by WordPress日本語ブログ at 2011.04.06

このメンテンナンスおよびセキュリティリリースでは、バージョン 3.1 にあった30件弱のバグを修正しています。以下で一部をご紹介します。

* メディアアップロードに関するセキュリティ強化
* パフォーマンス向上
* IIS6 対応のための修正
* タクソノミーおよび PATHINFO (/index.php/) パーマリンク修正
* クエリおよびタクソノミーとプラグイン互換性に関する各種エッジケース (まれに起こる問題) 向けの修正

バージョン 3.1.1 ではさらに、WordPress コア開発者でありセキュリティチームに属するジョン・ケーヴとピーター・ウエストウッドが発見したセキュリティ問題3点にも対処しています。一つ目は、メディアアップローダーでの CSRF 阻止の強化。二つ目は、一部の環境において、非常に悪意を込めて作成されたリンクがコメントに含まれていた場合の PHP クラッシュの防止。三つ目は、XSS 問題の修正です。

使ってても何も変わらないし、よくわかんないよね。
でも大丈夫。WordPressブログでも下記のように言ってるし。

リリースに向けた Haiku をここで一句。

Only the geeks know
What half this stuff even means
Don’t worry — update

(訳注: ギークだってこのうちの半分くらいしかよく分からないはず。でもご心配なく。とにかくアップグレード !)

俳句っていうけど、季語がないじゃん(笑

WordPress3.1にバージョンアップ、あれっ?

先日、WordPress3.1にバージョンアップしたところでしたが・・・


あれっ?

と思ったら、、

WordPress 3.1 日本語版リリースのお知らせ

ということだったんですね。
ということで、バージョンアップしました。

しかし、わかりにくいなぁ。。。
せめて「WordPress3.1-jaが利用可能です」ってな表示にしてくれれば、すぐわかるのにぃ。。

My関連エントリー
WordPress3.1にアップデート at 2011.02.25

WordPress3.1にアップデート

WordPress3.1にアップデートしました。
下記のブログを見るといろいろ新機能が追加になったようですが、
いまいちドコがかわったのか、わからない(^^;

関連ブログ
WordPress 3.1 をお楽しみください
by WordPress / 日本語 at 2011.02.24

このリリースの新機能をご紹介しましょう。高速スピードの内部リンクワークフローを使えば、既存の投稿やページへ簡単にリンクを作成できます。管理バーの登場により、よく使うダッシュボードページにいつでも数クリックで辿りつけるようになりました。スリム化した編集インターフェースでは、デフォルトであまり使わないパネルを隠し、よりシンプルで、初心者ブロガーでも心理的プレッシャーなく執筆ができるようにしました (管理画面の右上にある「表示オプション」タブから、隠れたパネルを再度表示できます)。 また、個人設定画面から選べる青系の管理画面をリフレッシュしました。

 
 

WordPress3.0.5へアップデート

WordPressのバージョン3.0.5がリリースされたので、早速アップデートしました。
どこか何か変わったということはありませんが、

重要なセキュリティ改善・向上が含まれています。

ということなので、WordPressご利用の方はアップグレードしておいた方がよろしいでしょう。
もっとも、@Niftyのラクーカンサーバの場合は、相変わらず、

The update cannot be installed because WordPress 3.0.5 requires MySQL version 4.1.2 or higher. You are running version 4.0.27.

ということでダメでしたが。
ホント、やる気ないのね、@Nifty。。。

関連ニュース
WordPress 3.0.5 (そして、3.1 リリース候補 4)
by WordPressブログ at 2011.02.08

My関連エントリー
続・@Niftyからの回答 at 2011.01.04

WordPressを3.0.4にバージョンアップ

おいおい、こんな年の瀬にバージョンアップ?
と思いつつも、ボタンを押すだけの簡単自動更新なので、即実施しました。
 
また、バージョンアップ後に、テンプレートの変更は不要でした。
まぁ、使っているテーマにバージョンアップがあった訳じゃありませんからね。
 
なお、今回の修正内容は以下だということなので、WordPressご利用の方は、なるべく早くバージョンアップすることをお勧めします。
 
3.0.4 重要なセキュリティアップデート
by WordPress / 日本語 at 2010.12.30

このアップデートでは HTML をサニタイズする KSES と呼ばれるライブラリーにあるコアのセキュリティバグを修正します。このリリースをランク付けするなら、”critical” (重要) になります。

 
ところが、、、
@Niftyのラクーカン上に構築している「WordPressなんて簡単さ、なんて嘘さ。」の方は、、、

The update cannot be installed because WordPress 3.0.4 requires MySQL version 4.1.2 or higher. You are running version 4.0.27.

ということで、やっぱりバージョンアップできませんでした。
ダメダメ@Niftyさん、来年こそは、MySQLのアップデート、頼みますよ!